SPSS Workshop #2 @ UBC Research Commons. 2016

Part 1: Data Management

The Sort Cases Command

Menu: Data—Sort Cases

Using the sample data by following the path as below:

Program Files-IBM-SPSS-Statistics-23-Samples-English-Survey sample.sav

You may want to list the respondents by age.

Step by Step:

Select Age of respondent(age) from the variables on the left, click the arrow button to
put it to Sort by box.

You may select Sort Order

Click ok

The Select Cases Command

Menu: Data—Select Cases
10 00 Select Cases

Select

+ Respondent id n... @ All cases

&> Labor force stat... -
& Marital status [... _ If condition is satisfied

& Number of child... If...
& Age of respond...

& Highest year of... ) Random sample of cases

& Highest year sch... Sample... Approximately 20% of the cases
f Highest year sch... i

& Highest year sch... (_) Based on time or case range

dj Highest degree... Range...

&> Gender [sex] )

&> Race of respond... () Use filter variable:

&5 Born in this coun... -

&5 Parents born in...
f How many gran...
4l Total family inco... Output
:[I Respondent's in...

- *) Filter out unselected cases
il Think of selfas I...
dj Favor or oppose... Copy selected cases to a new dataset
&) Belief in life afte... Dataset name
4l General happin...
4l Happiness of m... Delete unselected cases
L - .

Current Status: Do not filter cases

Reset Paste

| Cancel | l OK ]

)

1. Option 1- randomly selecting cases

Select Random sample of cases, click on Sample, indicate you want approximately



20% of all cases.

Now look at the Data View of the file, and you will see that many cases are crossed
out (approximately 80%).

(You may get the frequency of any of the vairables to find out how many cases are
kept. )

To bring back the unselected cases into the analysis, just open the Select Cases
window and choose All cases.

2. Option 2: Selecting cases that satisfy a condition
Click on If condition is satisfied button, then click on the If... button.
Suppose you wish to select only the female respondents. Get the window below:

8 00 Select Cases: If
& Number of child... pr sex = 2|
& Age of respond...
& Highest year of... (A GRS
& Highest year sch... — = Al ’
& Highest year sch.. =l [>] [7]18]1S
& Highest year sch... - o
1 Highest degree. .. | - <=| [>= 45|86 E:Z)):Vir:z:central CoF
&> Gender [sex] R — )
e I D3] o
&> Born in this coun... Date Creati
&> Parents born in... L] [&] [ LU () :E? r.'fi“_c.’f._
ﬁHOWITanY' gran... =] 2] 0 Delete e Functions and Special Variables:
Total family inco... L |
Abs
ﬂ Respondent's in... Arsin
i Think of self as I... Artan
i Favor or oppose... Cos
&> Belief in life afte... Exp
il General happin... Lg10
ﬂ Happiness of m... Ln
&> Have gun in ho... Lngamma
1l How often does... Mod
6¢z Hours per day... Rnd(1)
(7 | Cancel | Continue

Place the Gender(sex) variable in the box on the top, and click on = from the
components, and type 2 in order to formulate an expression: sex=2

Click on Continue to come back to the last dialogue window and click on OK. The
cases that meet the condition will be selected.

The Compute command
Menu: Transform—Compute Variable

Use the dataset driving task.sav
You want to get the average errors for daytime and nighttime task.

Step by step:



e OO0 Compute Variable

Target Variable: Numeric Expression:

Type & Label...

& Respondent id n... ‘ - |
&> Labor force stat... s
&> Marital status [...
& Number of child...
& Age of respond...
& Highest year of...
& Highest year sch...
& Highest year sch...
& Highest year sch...
41l Highest degree...
&> Gender [sex]

&> Race of respond...
&5 Born in this coun...
&> Parents born in....
& How many gran...
i Total family inco...
4l Respondent’s in...
ol Think of self as I...
il Favor or oppose...

Function group:

All

Arithmetic

CDF & Noncentral CDF

o]
E Conversion
3]
L]

Current Date/Time
Date Arithmetic
Date Creation

RENERDINE
(] [=] [=] [&] []

*»
*»

(7) Delete s Functions and Special Variables:

[ .. | (optional case selection condition)

?) | Reset | Paste | Cancel | OK

1. In the Target Variable box: enter the name for your new variable, e.g. average
Click Type &Label to assign the label to this variable

2. Function group select All

Scroll down, select Mean, double click to allow it appear on the top box of Numeric

Expression: MEAN(?,?)

3. Select errors in daytime task (Daytime) from the left variables, double click
Select errors in night-time task (Nighttime) from the left variables, double click, and

you will get this:
Target Variable: Numeric Expression:
Average = MEAN(Daytime,Nighttime)

4. Click Paste, in the syntax window you should get the following command:
DATASET ACTIVATE DataSetl.

COMPUTE average=MEAN(Daytime,Nighttime).
EXECUTE.

Now run this command and you will get a new variable average.



The Recode command
Menu: Transform— Recode into Different Variables...

Use the dataset survey sample.sav
You want to group the values of the hours per day watching TV in your sample into

two groups:

Old Value New Value New label

0,1,2 1 2 hours or less

3 and above 2 3 hours and more
Step by Step:
®0O® Recode into Different Variables

R Numeric Variable -> Qutput Variable: Output Variable
41l Respondent's in... tvhours --> tvhours1 NaiE:

ol Think of self as I... i
dj Favor or oppose...
&) Belief in life afte. .. Label:

4l General happin... (¢

,{I Happiness of m... S’

&> Have gun in ho...
41l How often does...

,{I How get paid la...

&> Country of famil...

&3 15t mentioned c... | Old and New Values... |

&5 2nd mentioned...
&> 3rd mentioned...

4l Confidence inb...
LB N

tvhours1

If... | (optional case selection condition)

7 | Reset | Paste Cancel | OK

1. Select the variable Hours per day watching TV (tvhours) from the list of variables
on the left, and place it into the box Numeric Variable-> Output Variable.

2. Type a new name in the Name box of Output Variable. We will call it tvhours].
Give it also a Label. Type Hours per day watching TV into two groups
Click on Change. The new name will appear next to the old name in the central box.

3. Click on the Old and New Values button. This is where you are going to define
the three categories you want for your new variable. Get the window as follows:



[ ] Recode into Different Variables: Old and New Values

Old Value New Value
Value: © value:
System-missing
System-missing Copy old value(s)
System- or user-missing Old ——> New:
Range: Lowest thru 2 --> 1

3 thru Highest --> 2

through
Range, LOWEST through value:

© Range, value through HIGHEST:
Output variables are strings Width

All other values

Rélp Cancel | uONtUELy

1) Click on the button Range, LOWEST through value, and type 2

2) Type 1 in the Value box, then click the Add button. You should now see
the phrase Lowest thru 2a2 appearing in the Old-aNew box.

3) Click Range, Value through HIGHEST, and type 3

4) Type 2 in the Value box, then click the Add button. You should now see
the phrase 3 thru Highest --> 2

4. Click on Continue. Got back to the previous dialog box.

5. Click on PASTE. This command created and pasted in the syntax window should
be:

DATASET ACTIVATE DataSetl.
RECODE tvhours (Lowest thru 2=1) (3 thru Highest=2) INTO tvhour2.
EXECUTE.

Run this command. You have now created the new variable nhours].

This new variable does not have value labels yet. Nothing tells you what 1, 2 stand
for. To add value labels, click on Variable View of the data Editor, and scroll down to
the end of the list of variables. Your new variable should now be listed. Click on the
righ-hand side of the cell corresponding to the values of tvhoursl, the dialog box now
appears. Type in the value labels.



[CHeNs) Value Labels

Value Labels
Value: Spelling...

Label:

1.00 = "1 or less hour”
Add 2.00 = "more than 1 hours, up to
3.00 = "above 3 hours"

Chnange

nemove

Help Cancel OK

The Aggregate Command

Menu: Data- Aggregate

You want to know the average hours of watching TV of the families with different
levels of family income.

Step by Step:

Select Total family income—click the arrow it to put it to Break Variable

Select Hours per day watching TV—click the arrow to put it to Summaries of
Variables

The default is to calculate the Mean, but You can change it by clicking Function
Select “create a new dataset containing only the aggregated variables’

Click OK
Exercise 1:

Program Files-IBM-SPSS-Statistics-23-Samples-English-Survey sample.sav
Please create a new variable by recoding the variable Think of self as a liberal or
conservative (polviews). The old variable has 7 categories (1=Extremely liberal,
2=liberal, 3=slightly liberal, 4=moderate, 5=slightly conservative, 6=conservative,
7=extremely conservative) except three missing values (0,8,9). You want to recode the
7 categories into three: 1=liberal, 2=moderate, 3=conservative.



Part 2: STATISTICAL TESTS

Independent T test

1. Click Analyze > Compare Means > Independent-Samples T Test...

2.You will be presented with the Independent-Samples T Test dialogue box, as shown below:

) Independent-Samples T Test “

Test Variable(s):

‘&> Treatment
& Cholesterol

Grouping Variable:
N |
[:] @eset ][Cancel][ Help ]

3. Transfer the dependent variable into the Test Variable(s): box, and transfer the independent

variable, into the Grouping Variable: box, by highlighting the relevant variables and pressing

the buttons.

4. You then need to define the groups. Click on the button. You will be
presented with the Define Groups dialogue box, as shown below:

5. If you need to change the confidence level limits or change how to exclude cases, click the

M button.
6. Click the button.

Paired Sample T Test

1. Click Analyze > Compare Means > Paired-Samples T Test... on the top menu.



2. You will be presented with the Paired-Samples T Test dialogue box, as shown below:

ta Paired-Samples T Test | x |

Paired Variables:

Pair |Variable1 |Variable2
1

:] Lgeset ][Cancel][ Help ]

3. Transfer the variables into the Paired Variables: box. There are two ways to do this: (a)

click on both variables whilst holding down the shift key (which highlights them) and then

pressing the button; or (b) drag-and-drop each variable separately into the boxes. If you
are using older versions of SPSS Statistics, you will need to transfer the variables using the

former method.

4. Click the button.

One way ANOVA test
1.  Click Analyze > Compare Means > One-Way ANOVA... on the top menu as shown
below.

2. Transfer the dependent variable into the Dependent List: box and the independent variable

into the Factor: box using the appropriate @ buttons (or drag-and-drop the variables into
the boxes)

3. Click the button. Tick the Tukey checkbox as shown below:



~Equal Variances Assumed

LSD S-N-K Waller-Duncan

Bonferroni W Tukey Type Type Il Error Ratio: [100

Sidak Tukey's-b Dunnett
Scheffe Duncan Control Category : [Last
R-E-G-WF Hochberg's GT2 [ Test

R-E-G-WQ Gabriel @ 2-sided @ < Control @ > Control

~Equal Variances Not Assumed
Tamhane's T2 Dunnetts T3 Games-Howell Dunnetts C

Significance level: |0.05 |

4. Click the E button. Tick the Descriptive checkbox in the —Statistics— area, as

shown below:

~Statistics
Fixed and random effects
Homogeneity of variance test
Brown-Forsythe
Welch

Means plot

Missing Values

® Exclude cases analysis by analysis
© Exclude cases listwise

5. Click the E button.



Correlation

1. Click Analyze > Correlate > Bivariate...

2. Transfer the variables into the Variables: box by dragging-and-dropping or by clicking the

EJ button.

3. Make sure that the Pearson tickbox is checked under the -Correlation Coefficients- area

(although it is selected by default in SPSS Statistics).

3:t Bivariate Correlations

Variahles:

Options...

Correlation Coefficients
([Z Pearson [ | Kendall's tau-b [ Spearman

Test of Significance
(@ Two-ailed © One-tailed

¥ Flag significant correlations

[ OK ][Easte ][ﬁeset ][Cancel][ Help ]

4. Click the M button. If you wish to generate some descriptives, you can do it here

by clicking on the relevant tickbox under the -Statistics- area.

5. Click the button.

Linear Regression

1. Click Analyze > Regression > Linear... on the top menu.
2. Transfer the independent variable into the Independent(s): box and the dependent variable

into the Dependent: box. You can do this by either drag-and-dropping the variables or by

using the appropriate buttons. You will end up with the following screen:



~ Dependent:
=)

rBlock 1 of 1

|} Previous | W

Independent(s):

£2

Method: |Enter ¥

Selection Variable:

’E‘ | | | Rule... |

Case Labels:

=

~—, WLS Weight:

3. Click the m button. This will generate the results.

Crosstab

1. Click Analyze > Descriptives Statistics > Crosstabs...
2. Transfer one of the variables into the Row(s): box and the other variable into the

Column(s): box. You can either: (1) highlight the variable with your mouse and then use the

relevant W buttons to transfer the variables; or (2) drag-and-drop the variables. How do
you know which variable goes in the row or column box? There is no right or wrong way. It
will depend on how you want to present your data.

If you want to display clustered bar charts (recommended), make sure that Display clustered
bar charts checkbox 1is ticked.



3. Click on the E button. You will be presented with the following Crosstabs:

Statistics dialogue box:

[~]iChi-square : [] Correlations

~Nominal ~Ordinal
Contingency coefficient Gamma
Phi and Cramer's V Somers'd
Lambda Kendall's tau-b
Uncertainty coefficient Kendall's tau-c

~Nominal by Interval Kappa
Eta Risk
McNemar

Cochran’s and Mantel-Haenszel statistics
Test common odds ratio equals: |1

(Continue | Cancet {_tetp ]

4. Select the Chi-square and Phi and Cramer's V options.

5. Click the E button. You will be presented with the following Crosstabs: Cell
Display dialogue box:

~Counts ~z-test

[¥ :Observed Compare column proportions

Expected B Adjust p-values (Bonferroni method)

Hide small counts
Lessthan =

~Percentages ~Residuals
Row Unstandardized
Column Standardized
Total Adjusted standardized

~Noninteger Weights

@© Round cell counts  © Round case weights
© Truncate cell counts © Truncate case weights
© No adjustments

(Continue} {_cance J(_telp |




6. Select Observed from the —Counts— area, and Row, Column and Total from the —

Percentages— area,

7. Click the button to generate your output.



2016 SPSS Workshop #2 Resources

Categories Questions Resources
SPSS I want to get tutorials on | « SPSS Statistics Essential Training - Tutorial via
Functionalit | the general features of | Lynda.com. This is a subscription site, you should
ies SPSS have access via VPL (Vancouver Public Library) if
you have a library card.
http://calcnet.mth.cmich.edu/org/spss/toc.htm- SPSS
On-Line Training Workshop Central Michigan U.
http://www.statisticshowto.com/spss-how-to-index/-
Statistics How to
S P S S| Where can I find more | www.pearsonhighered.com/george. - Pearson
Exercises exercises on SPSS in
order to master the
functionalities?
SPSS case | Where can 1 find | SPSS->Help->Case Studies
studies examples of how to
create statistical analysis
and how to interpreted
the results?
Statistics | « What statistical | » http://www.ats.ucla.edu/stat/spss/whatstat/

relevant to
SPSS

analyses should I run?

* What are the
prerequisite of running
a criteria?

* How to interpret my
output?

whatstat.htm#1sampt - UCLA
« http://www.cbgs.k12.va.us/cbgs-document/research/

Stats%20For%20Dummies.pdf - Statistical testing
basic guide)

* http://www.biostathandbook.com/testchoice.html

* http://bama.ua.edu/~jleeper/627/choosestat.html-
Table of statistical test

SPSS Software ->Help-> Statistics Coach

Research
methods

I want to understand the
meaning of a variety of
statistical analyses, and
the links
analysis and the types of
variables.

between the

Bryman, Alan. Social research methods. Oxford
university press, 2012. Chapter 15 Quantitative
analysis

Please provide us with Feedback: http://koerner.library.ubc.ca/services/

Commons Feedback Form)

research-commons/research-commons-feedback-form/ (Or Search: UBC Research



http://koerner.library.ubc.ca/services/research-commons/research-commons-feedback-form/
http://www.lynda.com/SPSS-tutorials/SPSS-Statistics-Essential-Training/182376-2.html?utm_source=google&utm_medium=cpc&utm_campaign=l1-CA-Search-Biz-SPSS&cid=l1-ca:en:ps:lp:prosc:s29:1009:all:google:xct-spss_tutorials&utm_content=65219751546&utm_term=spss%2520tutorials&device=c&gclid=CNCYsJmo_MgCFUiEfgodbcsOTg
http://calcnet.mth.cmich.edu/org/spss/toc.htm-
http://calcnet.mth.cmich.edu/org/spss/toc.htm
http://www.statisticshowto.com/spss-how-to-index/-
http://www.pearsonhighered.com/george
http://www.ats.ucla.edu/stat/spss/whatstat/whatstat.htm#1sampt
http://www.cbgs.k12.va.us/cbgs-document/research/Stats%20For%20Dummies.pdf
http://www.biostathandbook.com/testchoice.html
http://bama.ua.edu/~jleeper/627/choosestat.html

Outside Resources for learning SPSS
@ UBC Research Commons., 2016

UBC’s resources for statistical consulting:

If you have questions about statistical analysis methodology, please visit the
Department of Statistics' Statistical Consulting and Research Laboratory
(SCARL) http://www.stat.ubc.ca/SCARL/ website for information.



http://www.stat.ubc.ca/SCARL/
http://www.stat.ubc.ca/SCARL/

